New Model O 2 Pro Wireless mode is not responding (need to toggle off on to work again)

Hi, I am getting a weird issue.

I recently had an issue with my Model O wireless which is all good now. I am now just using that for my work computer on wired mode.
I don’t have any other wireless devices near me now too, no bluetooth etc.
I even formatted and installed freshly windows 11.

The problem is, my Model O 2 Pro is not responding (need to toggle off on to work again).
So as I mentioned on the subject. The annoying part is it only happens on all my games.
When I am using it browsing, watching / streaming etc; it happens too but more seldom.

I have tried all the option I have which are the uninstall/reinstall of the core software, even updating the firmware and so but the issue is still RANDOMLY happens, even recently tried the reset factory by holding down the mouse keys.

Is this a faulty hardware or is it probably a bug that will be fixed soon? I am confused as to why this is happening on this new mouse. My older Model O Wireless don’t have this issue, though prior I formatted my pc and all as I was using the Model O Wireless, I had that stuttering issue on certain applications, not even games.

This issue right now is WORSE considering this is a new one. :frowning:
Sad part for me, it is outside the return refund already and if I were to send it back to the store I purchased it locally online, it would go for repair or something which leaves me on not having a mouse to use. I could use my old one but it’s on my work computer now though.

Hey, there are a lot of variables that could be causing the issue in your specific case. Your best bet is to contact support. They will be able to chat you in real time and diagnose the problem.

You can reach out to them here:

I was thinking that someone would refer me there to be honest but I tried that live chat but it is not working even on my other browser as well.
Email is working though but I did not submit anything yet.

Support is checking with me now, finally figured out how the live chat works lol but at the same time they have the email support, thanks! Will keep everyone posted.


I must be honest; this also happens with my Model O 2 Pro. I just have not had time to reach out to support yet… I suppose I will need to as well. Keep us posted for sure, @booterbotter, It’s not a fun time to have this happen in build fights in Fortnite or being chased by a horde in MWZ fo sho! :slightly_frowning_face:

IKR, I mean wired is fine but the reason why you bought a wireless mouse is to be able to get rid of the wire when doing flick shots and stuff.

Which version do you have? The 1k or the 4k/8k version? I heard of other gaming mice having issues with some games if the polling rate is set to over 1k polling rate.

1k, I never was a fan of higher than that since I heard it consumes more battery power.

Just wanted to update that Support is still working with the Developers on this. They said that the devs are planning to role out a firmware update patch.

“in the process of working on a firmware update for the Mouse which could potentially resolve the issue being experienced.”

Kinda skeptical on the ‘potentially resolve the issue being experienced’ :frowning:

I mean, I was expecting it to be stable and all since it’s been launched for a few months already.
The 2.4Ghz adapter is literally 5-6 inches or sometimes even 3 inches away from the actual mouse, and the mouse would suddenly intermittently not work at all. DPI button mapped on battery charge status works though, and the DPI light on the bottom is working fine.
The only solution when this happens is to turn off/on or unplug/replug the 2.4Ghz usb adapter which is honestly a pain specially if you are playing FPS games or games that you can’t afford to be a few seconds delayed.

I would want to note out though that ever since I placed the 2.4Ghz usb adapter closer on the mouse, it is happening less now compared to before but still it sux that it happens even when you are just watching netflix or browsing :frowning:


Thanks for the update on this @booterbotter! I know it sucks for sure. I am getting hit with it about 2-4 times a week (mostly in games) if I run it in wireless. Here is hoping they lock it in on this patch, whenever it comes out. :crossed_fingers:

I just bought this today and it happened within a couple hours. twice. Pain

:crossed_fingers: Soon :tm:

This is their reply


Update for everyone, it looks like the fix is out. Email just came in to me an hour ago.

1 Like

Hoping it works fine for everyone. Please update here as well if it worked for you.


1 Like

@booterbotter thanks for updating us that they have updated for this. I have also taken the steps to update and the mouse will be my daily driver for the next few days and I will update here how it is. I do want to point out that the picture of your mouse and the firmware is not corrrect, you are showing the and it should be updated to - just in case you come across any issues.

1 Like

Thanks, not sure if it’s because I’m using the 1K variant since the change logs are indicating 4k/8k but I’ve asked Glorious support about it.

That is my bad actually. I see on the update site that you appear to be on the version that came out for the 1k variant on the same day. :+1: Has completely changed this mouse for me. From battery life to quality of signal. Thank you to the dev team for getting this fixed!!!

With this correction, you should feel really confident releasing the Series One Pro 4K/8K because this performance in that form factor is a shoe-in for the mouse of year for 2024. :wink:

Until then, this is the main. W Glorious!

1 Like

Yeah for 1Khz the fw version is the same as Glorious Support confirmed with me. Still

The 4k/8k variants who have the same issue should have fw version and that should fix the issue as well for everyone :smiley:

1 Like