QMK Guide for GMMK 2

Hey everyone - our awesome copywriter @Zach made a guide for how to install QMK on your GMMK 2. Check it out here, and let us know if you have any questions!

6 Likes

I tried running these steps, but the QMK branch that’s listed doesn’t appear to exist. At least not on github. I’m running QMK inside WSL for ref:
Ψ Found qmk_firmware at /home/qmk/qmk_firmware.
Ψ QMK Doctor is checking your environment.
Ψ CLI version: 1.0.0
Ψ QMK home: /home/qmk/qmk_firmware
Ψ Detected Linux (WSL).
Ψ Git branch: master
Ψ Repo version: 0.16.7
Ψ All dependencies are installed.
Ψ Found arm-none-eabi-gcc version 8.3.1
Ψ Found avr-gcc version 8.3.0
Ψ Found avrdude version 6.3
Ψ Found dfu-util version 0.9
Ψ Found dfu-programmer version 0.7.0
Ψ Submodules are up to date.
Ψ QMK is ready to go

[qmk@skitzo2000 qmk_firmware]$ git checkout gmmk_v2_keyboard
error: pathspec ‘gmmk_v2_keyboard’ did not match any file(s) known to git <<<

*Note I got this working with a fresh copy of QMK_MSYS this might work in WSL if you spin up a new env.

Ok so we aren’t totally home free yet. Its complaining about the bootloader and I need a little help debugging: rules.mk does specify a bootloader: BOOTLOADER = wb32-dfu
See below for output

[pnorton@L-PA-PNORTON1 qmk_firmware]$ qmk compile -kb gmmk/gmmk2/p65/ansi -km default
Ψ Compiling keymap with make --jobs=1 gmmk/gmmk2/p65/ansi:default


QMK Firmware 0.15.25
Making gmmk/gmmk2/p65/ansi with keymap default


 * No bootloader specified. Please set an appropriate 'BOOTLOADER' in your keyboard's 'rules.mk' file. [ERRORS]

builddefs/bootloader.mk:207: *** Invalid BOOTLOADER.  Stop.
Make finished with errors
make: *** [Makefile:413: gmmk/gmmk2/p65/ansi:default] Error 1

Hey there! Thanks for reaching out :slight_smile:

I chatted with our dev team and it looks like you have an old qmk_firmware folder that needs to be renamed or removed. After this is done you can start the process again and it should work correctly. Please let me know if you’re still having issues though!

1 Like

Sorry to keep Hounding you guys but I’m still struggling to get qmk on my keyboard.

I’ve created my layouts and compiled everything, but The QMK toolbox version you linked seem to be missing the driver possibly?

*** QMK Toolbox 0.1.1 (https://qmk.fm/toolbox)
    Supported bootloaders:
     - ARM DFU (APM32, Kiibohd, STM32, STM32duino) via dfu-util (http://dfu-util.sourceforge.net/)
     - Atmel/LUFA/QMK DFU via dfu-programmer (http://dfu-programmer.github.io/)
     - Atmel SAM-BA (Massdrop) via Massdrop Loader (https://github.com/massdrop/mdloader)
     - BootloadHID (Atmel, PS2AVRGB) via bootloadHID (https://www.obdev.at/products/vusb/bootloadhid.html)
     - Caterina (Arduino, Pro Micro) via avrdude (http://nongnu.org/avrdude/)
     - HalfKay (Teensy, Ergodox EZ) via Teensy Loader (https://pjrc.com/teensy/loader_cli.html)
     - WB32 DFU via wb32-dfu-updater_cli (https://github.com/WestberryTech/wb32-dfu-updater)
     - LUFA Mass Storage
    Supported ISP flashers:
     - AVRISP (Arduino ISP)
     - USBasp (AVR ISP)
     - USBTiny (AVR Pocket)
*** WB32 DFU device connected (NO DRIVER):  WB Device in DFU Mode (342D:DFA0:0100)

Ok so anyone else finding this, this is a Windows 11 specific issue. And the solution will work for the 65% and 96%.

You will want to use a program called zadig (https://zadig.akeo.ie/) to install the correct drivers for Windows 11.

Run the zadig prog above.

Go to options>list all devices

You will see a list of USB devices, and zadig will tell you what drivers they are using(if any). Don’t install anything yet.

Put your GMMK 2 65 into bootloader mode by plugging in the cord while holding b and spacebar.

You will see a new device in the device list called “WB Device in DFU mode” Select it and below it will show you you have no driver.

I installed the libusb-win32(honestly other drivers may work as well or better this is what worked for me).

This screen shot is after I installed the libusb-win32 driver.

Screenshot 2022-03-26 154006

Note you will need to unplug and replug your keyboard to get it to work again after its in bootloader mode.

After installing the right driver, the keyboard should show up correctly in QMK tools when you put it in bootloader mode. You have to use the QMK Tools that glorious has provided as the standard qmk_tools doesn’t have support for the WB32 yet.

@goldfish.paul Hey there! So sorry for the delayed response here - just to confirm, you did get everything working with QMK/your GMMK 2? If you’ve still got any issues happening let me know and I can check in with our dev team to get them solved.

Thanks @Millions yes I did. The problem is windows 11 specific if you guys want to update your guide with the info from above.

I also made the guide over here: https://gloriousforum.com/t/custom-qmk-for-gmmk-2-65-by-skitzo2000/11883

skitzo2000 is my usualy username. But it wasn’t available here =(

2 Likes

This dude QMKs

Seriously though. This is some amazing work you are putting in.

2 Likes

Thank you kindly sir!

I have a couple of questions. First will Core still work after flashing QMK to my GMMK 2 and second how easy is it to flash stock firmware back if you don’t care for QMK?

Good question! Glorious CORE only works with the default firmware, therefore it won’t work with a QMK flashed GMMK 2. As for flashing stock firmware back, please follow the steps in this support article to revert your keyboard back to the original Glorious firmware: https://glorious.gorgias.help/en-US/gmmk-2-reverting-keyboard-to-default-firmware-(glorious-core)-45608

Thanks for the response Millions. I haven’t flashed QMK yet, I was just doing some research before I did.

1 Like