Custom QMK for GMMK 2 96% - by Skitzo2000

As promised, I’ve finished porting my 65% QMK layout into a 96% version!

I’ve also enhanced the template to make it a little easier to work with, I would love your FeedBack!

Here’s my keymap:

I built this to help out the GMMK community get a jump start on their QMK Builds for the GMMK 2 96% ANSI Keyboard

* Most default Glorious shortcuts enabled
* Custom Colors For default Glorious shortcuts
* N-key Rollover (NKRO) enabled 
* Fn-\ or Fn-ESC for Bootloader mode
* Four Layers, 3 To customize and a function layer
* Macro's included via the macro.h
* Custom Glorious Sides Function to set side Colors
* Sample layers to copy and paste, etc

Notes:

You have to use the QMK Tools that glorious has provided as the standard qmk_tools doesn’t have support for the WB32 yet.

If you have QMK_MSYS already installed you will need to delete the existing qmk_firmware directory to make sure you’ve got the right qmk fork and branch with the right glorious firmware. Just follow the guide instructions for QMK_MSYS after you’ve backed up moved/deleted/renamed the existing folder.

If your on Windows 11, libusb doesn’t pickup the board in bootloader mode. You will need to use zadig to install the right driver. I’ve already posted instructions on the original QMK announcement thread over here.

I’ve tried to improve the documentation a little, and I’m working on some custom side animations for both keyboards! Again feedback is helpful!

3 Likes

This is great! Thank you very much for setting this up! Makes my life a bit easier that’s for sure.
I’ve built a keyboard layout to attempt to get this to work with VIA but when I build your keymap, I’m met with an error about not enough endpoints:

" error: #error There are not enough available endpoints to support all functions. Please disable one or more of the following: Mouse Keys, Extra Keys, Console, NKRO, MIDI, Serial, Steno"

Any suggestions on how I can go about that? I’ll never use MIDI, Mouse Keys, Serial, or Steno.

1 Like

Thanks, I built it to help the community, glad it’s doing its job, well sort of…

On your rules.mk just disable those modules. Check the qmk documentation for the specifics on how. Did you post an issue on GitHub? If you thinks it’s my code we should continue discussion over there so the convo is more visible to others who may have grabbed it.

1 Like