Model O Pro disconnect randomly.

Just want to put this out there, but have had the model O pro randomly disconnect in both wired and wireless mode. It just abruptly turns off (usually ~30 minutes of use, any application) in both wired and wireless mode. Confusingly it does not disconnect from the computer and the computer still recognizes that a USB device is plugged in. Unplugging / replugging or turning off / on seems to fix it. I tried firmware updates, resetting mouse, changing cables, changing USB ports, uninstalling and reinstalling the core, and pretty much any combination of all of the above. In the end I sent the mouse back for a replacement which showed up yesterday but it’s still happening even with a new mouse.

Not sure if it makes a huge deal, but the only quirky thing about my PC build is that I do have a USB PCI card for additional USB ports. The mouse isn’t plugged into that one it’s on the MOBO ports (or the front header ones) but I’ve read elsewhere that could cause issues in general.

The only reassuring thing is that “it’s still happening” so I think it’s a software issue rather than a hardware one. I just don’t know where to go from here and figured I’d share to see if anyone else is having anything similar. Curious if anyone else is experiencing anything similar.

Hey! The best way to get help with your specific case is to reach out to our support team. They’ll be able to troubleshoot with you and find a solution.

same happen to me but seen im out of warranty i have to get a new one :unamused: :smiley:

My son is having the same issue. The mouse works on other computers, but does not work on his main gaming PC. It varies between disconnecting every 20-30 minutes or, as it’s doing now, disconnecting every couple of minutes.

He has spoken online to the Glorious team, but they mainly said it was out of warranty and he should get a new mouse. However, is it not more likely to be a software/firmware issue than hardware? If it works on other computers and used to work on this PC - we are really desperate for help!

Not sure what exactly I’ve done differently this second time around. but after reinstalling the glorious core software, resetting the mouse, and then re-updating the mouse’s firmware, it hasn’t disconnected yet in wireless mode. That said I did do that yesterday and it didn’t work so I just went back to my older model O because I had to get some work done but figured I would give it another whirl today and try my luck and fingers crossed it was good all morning.

I’m running it in wired mode now which is actually I prefer to run it as and at least for the past hour it’s been OK.

I mean to me it still suggests some sort of software/firmware issue that updating / reinstalling seems to have fixed so far. Hope that helps others.