Model I disconnecting and reconnecting

Whenever I move the mouse, it somehow randomly disconnects and then reconnects after a few seconds. But when I leave the mouse alone, it doesn’t do that. Sometimes it gets really bad and it completely turns off and doesn’t work until I replug the USB. Anyone know how to solve this?

Sorry to hear your Model I is disconnecting randomly while in use @N0pb. I cant imagine how annoying that must be. I would recommend reaching out to the Glorious Support team for assistance. Thats going to be the fastest and most reliable way to get to the bottom of the issue.

I’ve already tried to but I can’t find my order ID because I was not the one that ordered it, it was my friend and I’ve asked him but he couldn’t find It either. But honestly, i don’t see the reason why they need my order ID, i just want to know how to fix my mouse. I’m just looking for someone who knows how to fix it because they had this issue before.

I’ve also tried looking online but no one on youtube has the same problem. Only some people have the same problem but they have a different product than mine and I’m not trying to waste money on something that would probably not work.

Interesting, Im not sure why they would need an order ID. @Bearenby @Millions either of you have suggestions?

thanks for trying to help btw

Hey @N0pb I’m guessing they’re asking for this preemptively so that if they determine your mouse needs to be replaced they can look up the corresponding order to move through that workflow. I’m sure they can take you through some troubleshooting steps without the order ID, but if it’s determined you’ll need a replacement to fix the issue they’ll need the ID to issue the replacement.

Let me know if they say they can’t walk you through troubleshooting without it and I can reach out to them directly.

4 Likes

ok thank you, will do that

I have the same problem too, it’s very annoying. when i move it slowly it doesn’t disconnect. and when i move it very fast it disconnect. for a 60$ mouse wtf is this

same here

Yesterday, I installed Windows 11 on my laptop moving from a fringe version of Linux, Arch. Arch managed the power of the mouse well shutting down the mouse when inactive and returning to the active state quickly. On Windows, the Glorious Model I 2 mouse is unusable. The mouse will disconnect with a few seconds of non-use and takes 10 to 15 seconds to reconnect again. This happens every time I take my hands off of the mouse.

I cannot state enough how terrible this performance is for a mouse that is not cheap and just plain unacceptable behavior. The company doesn’t seem to have any interest in addressing the issue. Unfortunately, this will probably be another company that fails under its own incompetence.