GMMK PRO keys not working

Hi, I bought a GMMK PRO about a month ago, along with glorious lynxs and the ocean keycaps. Four keys on my keyboard (A,S,D, and F,) all stopped working when I got onto my computer this morning. They were all perfectly fine last night, as I was playing Elden Ring. I’m not sure what caused these keys to stop working, but it’s odd to me that four in a row would stop working. Not sure what to do. I took keycaps and switches off, replaced switches with others I didn’t use, unplugged keyboard and re-plugged it in, rebooted computer. Tried blowing the area where you place the switches to see if there was any debris. Not sure if this is the right place to ask about this.

Hey Fireheart! Sorry to hear about the trouble with your GMMK Pro! I’d probably reach out to support to see what they have to say about it. My first suggestion would have been swapping the switches out.


I would add to try reflashing the firmware. You can force that in Core under settings. That’s likely your best next step.

Keep us posted on progress

1 Like

Not sure how to force it. GMMK PRO doesn’t appear in Glorious Core, since I used the QMK configurator. LEDs also turned off when I was trying to pull the switches out.

That sounds like a board issue based on how you are describing it. The only reason LEDs would turn off would relate to a break/short in the traces. Note that is pure speculation. I would reach out to support.

1 Like

Reached out to them. Said to switch out the switches (I did, still doesn’t work), reinstall firmware which I can’t do, and reset keyboard using FN+ esc and f1+ f3+f5. I’ll reach out to them about the LEDs too.

You can reinstall your QMK firmware using QMK Toolbox. Presumably you have that on your computer (and the firmware file) if you are using QMK.

I saw there was a recent firmware update to stop “key shuttering”

I’m not sure what that is, is it the same as double typing?

1 Like

I hope so, my spacebar double types all the time but is the only key that does it.


Yes I think so. I was having double input problems when typing recently. I updated the firmware yesterday and it’s fixed my issue.


I had double input issues on my GMMK Pro - but it was because of the foams I used - it was sandwiching my PCB pretty tightly w an extra 3mm Neoprene foam.

Now I just use Stupid fish PCB + Case foam, double tape mod, and o-ring mod on the screws, and it is absolutely fine with my PC plate, ink black v2, and Drop MT3 keycaps. No more ghosting / double presses.

No firmware issues. Polling rate 1,000 Hz, Input Latency 2ms

1 Like

Hey there @Fireheart! Was our CS team able to solve this for you?

Yes they were extremely helpful and i already have a replacement on the way


Awesome, glad to hear that :slight_smile:

1 Like