GMMK NumPad sleeps on wired connection?

Curious if anyone has a suggestion on this issue:

The GMMK NumPad seems to “sleep” after 10-20min of non-use. I have it on a wired connection (BT is off). The first keystroke after sleep wakes up the device but it does not register the keypress. This creates a (slightly) annoying requirement to hit a key twice to register the input. Has anyone else encountered this issue? Any workarounds?


I stumbled upon my own answer - it’s not really intuitive but turning off the inactivity counter for lighting in Glorious Core seems to keep the numpad active. Image:

Hope this helps anyone else who has been frustrated by this issue.

This Frustratingly solves the issue, but creates the additional problem of killing the battery life on my Model D Wireless. Does anyone know if there is a way to force that setting to be device specific?

1 Like