Gmmk Numpad Macbook USB connectivity

I’m not sure if this is the right place but I have a GMMK numpad that I use with my Macbook pro that doesn’t always connect when connected using USB. To be fair my setup consists of a USB hub that connects to a single USB-C cable with a magnetic connection to my Macbook, so there are some additional variables.

My issue is I have to disconnect and reconnect the usb from the gmmk numpad in order for the macbook to detect the device. I’m worried that doing that too much will wear out the connection.

I updated the firmware last week thinking maybe that would help but still no go. Also I have a gmmk pro that is hooked up the same way to the same usb hub and it works with no issues.

Does anyone have any suggestions?

1 Like

Just wondering, is it becoming unrecognizable every time you close your MacBook and that’s why you have to unplug?

Also, it shouldn’t cause too much damage. I would maybe unplug the USB A end from your hub rather than the USB C side on the Numpad, just because it is easier to replace cables and hubs rather than install a new PCB but either way, it’s a cheap fix if something does get damaged.

I’m not too sure about a fix if you already tried reflashing/updating the firmware (maybe try a new hub or try to plug directly into your Mac with an adapter)

You can always try the support team but, were always glad to try and help on the forum as well

The device becomes unrecognizable upon disconnecting the usb-c cable from the macbook. I have two macbooks, one for work and one for personal use so I have a single magnetic usb-c connection to connect my peripherals and it’s odd that the glorious mouse and gmmk pro work flawlessly every time but the numpad just seems to not be recognized. I’ve tried pressing numlock but that doesn’t even register on the numpad, as in the side lights don’t indicate it’s been pressed. Even disconnecting the usb-c and reconnecting doesn’t fix it so a new usb hub may actually help. l’ll try that.

Good callout of the usb-a end but that end is under my desk for cable management, but I’ll try a new hub.

1 Like

I just ordered a powered usb hub because I have suspicion that the my peripherals are drawing too much power which is causing a weird issue with the macbook’s usb port. I will update once I am able to test.

1 Like

That’s a pretty solid idea hopefully it works out. Have you tried using the Numpad without some of your other peripherals plugged in? Also maybe try to separate some of the higher power-drawing devices by putting them on the new hub and keeping the lower ones on your original hub. Could definitely just be some conflict in how much each device is drawing power from a single port

It’s been a few days since I’ve added a powered usb hub to my setup so I wanted to report back in case anyone else has the same issue. I am happy to say that having my GMMK pro and GMMK numpad and other peripherals plugged into a powered usb supply has fixed my issue. I’m so glad it did because it was driving me crazy.

Here’s a link to the one I bought

1 Like

Glad everything works thanks for keeping us posted