Double keypresses

Hey Guys,

So I was wondering, has anyone had an issue with the LYNX Switches and double key presses when typing? I just noticed that when I was typing the Letter E it would display EE. I changed the switch and the issue was fixed. I had a few other letters that did this so I swapped out the switches on them as well.
Can I fix the switches? Is there a reason it does that?( This is my first Custom KB)

Thanks,
-Steve

Are you using Glorious Core software? If so, if you change the latency settings this may have something to do with it. I had it on the lowest setting and would get double typing all the time thinking something was wrong. I replaced switches but the problem consisted until I read online that all the setting does is lower the debounce time. I installed QMK and haven’t had a problem since.

1 Like

Hey @stevierods let me know if adjusting the latency as @TheKickButler suggested helps your issue! If so, I’ll move this topic to another one that deals with key chattering. If not though, definitely reach out to support and they can help troubleshoot the issue further!

It was the switches. I haven’t had an issue once I replaced the switch. I haven’t had any other issues really.

1 Like

I checked latency and it looks good. It was the switches but thanks for answering

1 Like

Gotcha. In that case definitely let support know and they may be able to offer you some help with replacing the problem switches or something along those lines.

I had the same issue with the Panda switches, changed them to some spare Gatereon Red I had and its working perfect. Pretty disappointed but oh well.

I’m really sorry to hear you had the same issue. Can I ask if it was a couple switches or a large majority of the ones you purchased? I definitely want to pass all this info to our product team and see if they have any insights they could share.

I didnt test them all but I swapped the full set just in case. My guess is that they may be a bit overlubbed, could that cause some issue? I might open them up, unlube them and do some test later. Still I like how they feel overall.

I think I only had about 5 switches that had the issue. I’m new to this so I am not exactly sure how the switches are supposed to feel lol. I’m using the lynx switches now and I guess some keys feel smoother than others. I bought everything to lube myself from glorious so I guess that is my next step

I have had and continue to have it with several glorious panda switches. Seems to come on with my more used keys (wasd).
I’ve tried unlubing and it hasn’t really worked.

Update: two of my friends have GMMK Pros and both are double pressing and missing key presses. Started randomly and firmware update did not fix. One is using stock with panda switches and the other stock with kaihl purple pro switches. Figure I reach out and see if there was any new updates??
Thanks!

I had this issue with the GMMK Pro until I flashed some custom firmware onto the board. Solved all my problems with it and now I rather like it.

I’ve tried a few different switches, and don’t seem to change things (all unlubed): Boba U4T, Cherry MX Brown, Zealio V2, Gat brown, Box Brown.

All of the above produce chatter. The only thing that seems to fix things is just going to QMK. I do what to mention that it happens less on the stock firmware, but gets much worse after updating firmware

I’m having this exact same issue at the moment. I’ve not yet tried to open up the keyboard again, but am definitely planning to.
I might also just first try flashing some custom firmware on it, but I’m worried if I will lose the RGB customization support?

Hey all - just want you to know we do hear you and are tracking this as a known issue we’re working on. There’s an in-depth thread here started by @noodohs that discusses some potential fixes for this, and our UX/UI Specialist @kosmiclatte replied there confirming we’ve added it to our list of improvements.

1 Like

Sounds good thanks. My friends are giving me some heat because I told them how much I enjoyed the keyboard. I had a feeling it might be software related. I’ll check out that post and let me friends know. Thanks guys for replying and giving me that info to pass along

1 Like

Interesting. I thought it was just me… I’m only getting it on my space bar. I’m away from home for a few days, but I’ll swap the switch and see if that helps, then check latency.
GMMK TKL.

1 Like

Changed out the switch yesterday, and I haven’t noticed the issue anymore. :crossed_fingers:

2 Likes

Nice, I’ve been telling my friends to do the same but they lazy lol

1 Like