[solved]Model o wireless stopped working out of nowhere!

Hi yall,

as the title suggest my model o wireless stopped working all of a sudden.

I doesn’t turn on anymore.
Not with the battery and also not via cable.

-I tried resetting it by holding lmb + rmb + scroll button at the same time it didn’t work.
-I tried different cable

I had this issue once before but then I fixed it by plugging in the cable and unplugging it again

I have contacted the glorious support, but I don’t think they are going to help since I don’t have proof of purchase and the serial number underneath the mouse is wiped.

Welcome @shabli and sorry to hear about your mouse. I would reach out to customer support to see what they can do for you. Keep us posted on how it goes

1 Like

I have an update from the support team.

Thankfully they offered to send me a replacement mouse (I had to pay the shipping) or I could opt for store credit.

I opted for the store credit and put another $85 on top of it an bought the GMMK 2 65%


Happy you were able to get some resolution. The 65% is really nice. I use it for my work daily driver.


My first Mechanical Keyboard was the GMMK2 65% (Black) and I think you will be very pleased with it.

I have since given the GMMK 2 65% to my son who uses it to play Roblox, it’s got Glorious Panda Switches, White Pudding Keycaps & Aluminum WASD Keycaps (Chroma). He really likes it and I’m building a White GMMK2 65% for my cousin with Pink Glorious Pudding Keycaps and Pink Sakura Switches


Thank you guys for the replies,

I am very happy that I have made the right choice.

I can’t wait to receive it soon.

best wishes


Awesome, enjoy!