Odd keyboard problem

Keyboard is broken and working at the same time depending on what device its connected to. Anyone know what could be going on?

troubleshooting steps taken
flash gmmk with gmmk firmware using qmk tool
Reset gmmk using fn+esc+f1+f3+f5
Reinstall windows from usb with a formatted drive.
Cleared cmos
Updated bios

Support is already taking a look but maybe someone here knows a solution or what might be going on.

I don’t have an answer for you but I do have some questions, based on your troubleshooting:

Was it working before you flashed the firmware?

Why did you use the QMK tool instead of CORE to flash it?

Did you flash it via your laptop or your desktop?

Have you tried reverting to CORE instead of QMK?

Have you tried using motherboard ports instead of the front panel?

It’s super odd, it feels like something might be conflicting with the firmware on your desktop. Let us know if you hear back from support.

Keyboard was working, I went to cook dinner. came back and it wasn’t working anymore. I even paused hulu with spacebar when i went to cook dinner so It had to of died in the hour I was cooking.

I was instructed by glorious support to flash the gmmk back to their firmware using qmk tool. Just to clarify I never used qmk firmware or this qmk tool before this.
" Let’s try hard-resetting the GMMK PRO and reverting it back to the official Glorious firmware.

a) If you have the ANSI GMMK PRO, download our standard Glorious Firmware .bin file here.

b) If you have the ISO GMMK PRO, you will need this Firmware .bin file instead.

  • Open up the QMK Toolbox - get it from here.

  • Place your keyboard into bootloader mode (space+b and then plug into the computer, you should see a message that says STM DFU Bootloader).

(If your keyboard does not go into bootloader mode, do not worry! You can unscrew the backplate of the GMMK PRO. When you open your GMMK PRO (keys facing down) you will see a single button facing up towards you on the PCB Board. Simply hold that button down and plug your GMMK PRO into the computer at the same time. This is an override button that will place the GMMK PRO into DFU Bootloader mode.)

  • Open up the Glorious Firmware .bin file in QMK Toolbox and click flash.

  • That’s it! Your GMMK PRO will be back to using the original Glorious Firmware."

Flashed via laptop. pc does not recognize a device is plugged in.

I tested every usb port off camera. was one of the first things I did. My mouse and other keyboard work in every usb port but this gmmk flex doesn’t

I don’t understand how something on the pc can be conflicting with the keyboard. Clearing cmos updating bios and wiping my ssd installed windows from a usb should basically be a new computer. The keyboard should just work. I couldn’t even get it to work in bios or while installing windows. Which in 20+ years of working with computers I have never had a keyboard that didnt work in bios.

Another weird thing I noticed there are 2 other people with same or similar problems in the past week posted on this forum as well.

That’s strange they had you use QMK to try and revert your board if you never had QMK on it to begin with. Official firmware should be obtainable via Glorious CORE. Have you tried giving it an update through there? It should detect your board. How long have you had it? Could potentially RMA or get a replacement PCB. The support team has been questionable lately.

If it is detected just go down to Settings > Reinstall Firmware > GMMK PRO

1 Like

Does anything show up in device manager when you plug it in? Have you tried another cable (have to go down every weird route here, because who knows). Fresh Windows or not, there are posts going back years and years (outside of this forum) of people having keyboards that only don’t work on one computer and work fine on all the others they try.

I’ve killed PCBs before (literally while standing up due to shoddy ESD protection or lack thereof, who knows) that would still light up and would still make the USB sound in Windows but were, for all purposes, dead.

When the problem orignally happened my pc was saying port reset failed usb device unrecognized. It also took windows 10-15seconds to recognize a device got plugged in.

Now it shows nothing at all.

Yes i tried another cable. The one used in that video is brand new also. Took it out of the box just for that video lol

My keyboard seems to only work on that laptop. I tried it on all the smart tvs in the house and my computers.

Glorious core wouldnt detect my keyboard on my pc. I didnt try core on the laptop though. But i assume the results would be the same.

Try CORE on the laptop. That’s the only place it seems to be detected/getting power.

Yea. I will try it but I am assuming it will flash/work on my laptop and still wont work on my pc. Worth a shot but I feel like I already did this just with a different program. The firmware is still glorious.

They should have never had you using QMK to begin with. It really dosent make sense to me why they had you put it in boot loader mood and install 3rd party software. CORE flashes fresh firmware as long as the board is detected. If it is detected its a good sign your using glorious if its not you could still be stuck in QMK.

If it does not show up id say you have 3 options.

  1. Retry flashing it with using the files the support team gave you
  2. Flash it with QMK officially and use that insead (it should work with the keymap gui VIA)
  3. Try and get a replacement PCB

I believe they recommended qmk because my keyboard was not being detected by my pc. Could be wrong but thats my guess.

I attempted to update via glorious core. Core saw the keyboard and allowed me to update. But the firmware update got to 80% then swapped to saying NaN%. And is now stuck. The keyboard worked just before updating. Afraid to unplug it now lol

Its all good though. Just checked and its still under warranty. Support had told me it wasnt covered initially.

" All electronic products, excluding the GMMK 1, come with a 2-year warranty ."

I know I registered it too.

Are you running core in administrator mood?

I would get a hold of a different agent and have them try and get you a replacement.

Or ask them to escalate it (though not sure how that works with Glorious support, but it’s the go to line for any other support site when you seem at a stand still with support agents).

It was already escalated. Think i was talking to phoenix. Its already taken care of tho. They want to look at the pcb. Gets picked up today.

Thanks for the help everyone i appreciate it.

1 Like