My Model D decided to stop working

In this video you can see how my mouse is perfectly functional EXCEPT for the fact that it no longer moves against my mousepad! I have had it for 2 years or so and I have never seen this before

Any help would be very much appreciated.

1 Like

Interesting, what do you currently have the LOD (lift off distance) set to in the software?

1 Like

Hmm that is weird for sure. Yeah like @8-Bit_Bootcamp the only thing I could think of is checking the lift off distance in the Glorious Core to make sure that did not change somehow. I hope you are able to figure this out or someone else can help you with it. Good luck @tadhgon

2 Likes

Welcome to the forums @tadhgon!
I would say some canned air on the sensor from a little ways away from the mouse may help. You need good pressure, not just you blowing on it. It may be (half?) covered by some debris possibly, hence why your finger works and the mousepad isn’t. I would be curious if it tracks on other surfaces in this state as well. :thinking: I have a BIG bushy beard and I know I opened and cleaned my model D (no issues, was swapping a cable out) and saw that it needed it. Figured I’d throw in my two cents.

Edit to add more troubleshooting ideas
You can use a Q-tip and some alcohol (a good rum should do it, kidding, use rubbing alcohol) and make sure the mouse isn’t plugged in. You can clean the sensor with the Q-tip dipped in Grandma’s No No juice and wipe the sensor. Just make sure to give it a few minutes to dry and you should be good to test it out. :slight_smile:
End edit

Edited again to give examples of cleaning the sensor

Clean the sensor from the outside like this:

After you are done, drink the Q-tip:


End 2nd edit
Hope this helps!

Two years with one D. The dedication! :rofl:

7 Likes

I have the same problem today, everything works, but the cursor just does not move!!

HELP!!!

1 Like

Oh no, have you tried any of the steps @Indigochicken mentions in the previous post?

Is your Model D a Wireless or Wired? I know once and a while my Wireless Model D will lose its Wireless connection for a moment and the cursor will stop moving. Granted mine has never frozen and stopped moving altogether so my best guess would be to see if any of the steps @Indigochicken mentioned worked at all and if not then I would get a hold of Customer Support and see if they had any other troubleshooting steps they could give you or maybe they will just send you are replacement. Glorious has great customer service so don’t be scared to reach out

I really hope that you can figure out a solution and if not that you are able to get a replacement. Good luck :+1:

2 Likes

thats a glorious beard!

4 Likes

Thank you, friend! :pray:
Remain Glorious! :slight_smile:

4 Likes

It is the Wireless version

I have tried everything!
-Reinstal drivers/glorious core
-Reinstal Firmware
-Hard reset on the mouse
-cleaning the sensor

Nothing works!

2 Likes

Dang, then I would for sure get a hold of Customer Support and try and get a replacement. Glorious is usually pretty good about it and they may even send out the replacement first and once you receive it then have you send the defective one to them

Good luck and I hope it all works out for you

4 Likes

I already contacted them, they were super nice, they want me to send the mouse, but the problem is that i am from Ecuador, and it is super hard for me to send the mouse to the US, they understand that and as a long time costumer they send me a gift card wich is perfect because i have friends living in the US and they are coming for the holidays!!! so im super happy, as always Glorious deliver!

So i fell glorious!

4 Likes

Awesome!! I’m so glad it worked out for you and as always Glorious comes through. They are a great team over there :blush:

5 Likes

Woohoo!

4 Likes

LMAO XD