Model O wireless firmware update fails

If I open Glorious Core it says there is new firmware available.
When I try to update it says: An unknown error ocurred while updating. Please check that the usb cable and dongle associated with your device are connected and try again.
I tried to reinstall Glorious Core and tried to disable firewall and anti virus but nothing worked. any tips?

Hey @Sander2000, sorry to hear you’re having issues with your firmware! Please do reach out to our support team and they’ll help you troubleshoot the issue right away.

Plug both the mouse and dongle in and try that. You’ll need two cords so that you can plug both in.

3 Likes

This is the way. I struggled with this error for months. Plugging model O wireless in the original cable and then plugging the wifi dongle into another usb-c cable updated both for me. Thanks @SentientTD !

1 Like

Can anyone confirm the current Firmware? After many failed attempts I got lucky and tried the same thing suggested here. Just not sure it actually succeeded due to the glorious app crashing immediately after it hit 100% and then opening and failing again when I attempted a 2nd time.

I’ve had this issue ongoing for a long time. Sent in reports to tech support, I’ve tried manual installs. I tried 3 different computers with Window 8.1, Windows 10 and another Windows 10.

Top of all that, I’ve tried 2 different mice (sent the first one back). I’ve tried 2 different usb cables (dongle + original for mouse) and update ALWAYS fails on the Model O- Wireless.

If you do a google search, this same issue in the model O has been going on since 2020. Let’s not pretend they don’t know about it. They sell you the mouse, so if you like it out of the box, then great, just modify your lighting and move on, but don’t expect working updates.

I’m extremely disappointed in the response and decided not to get the keyboard after this whole experience. It’s even more disheartening to see others that have some how, allegedly, updated their mice.

1 Like

Yeah, I’ve the same problem. No amount of reconnecting/re-installing or different cables have helped.
On top of that I’ve unchecked the “open on startup” tickbox from the core sofware, and yet it persists on opening everytime I boot. And when it opens it just says everythings discconnected please reconnect :smiley: what a heap of BS software.

Thinking of returning the mouse after one day of use, the wired one and its software worked so much better. Thank GOD I didn’t invenst in the GMMK Pro.

Wow, glad to hear someone else having the same problem. They emailed me from tech support saying to check my anti-virus (which I don’t use).

The only way the software runs is if I run the .exe in administrator mode AND compatibility mode for windows 8.1. If I run it normal it wont even work. I can change the startup settings, and dpi / colors and all that, but honestly there were some updates we’ll never see because we can’t update.

I even asked if they can just update one on their end and I’ll trade them this one. They don’t do that though. I decided to try out a company I’ve been looking at for a while now and honestly I’m soooo happy I did. Xtrfy is amazing. They have similar mice with customizable shells (comes with 2). I got the M42 wired, but they have wireless options too.

Anyway, I love Glorious mouse bungee and wrist wrest, but that’s about where I stop. Sucks, I enjoy the mouse too, it’s nearly perfect design.

Yeah, only way the software worked for me also, win8 + admin. Funny part is when you uncheck the “start this program when computer starts” it actually still runs on boot but with the --hide parameter.

Anyway, my local retailer thankfully has a 60-day buy and try policy so it was pretty easy to return the mouse. And from what I heard, I wasn’t the only one to do so. I opted for Razer despite what the internet tells about their software, and atleast for me it was plug and play, zero issues.

I’m having the same issue as some of you here. I’ve been trying to update a piece of software on my Windows 11 machine, but every time I try to install the update, the software crashes and I get an error message in the Event Viewer.

I’ve tried running the update in compatibility mode and as an administrator, but neither of these solutions worked for me. Unfortunately, I’m also unable to update the software to the latest version, as the same crash occurs after downloading the update.

The error message I’m seeing in the Event Viewer is similar to what others have reported online:

[Application: FirmwareUpdate.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ArgumentException
at System.Text.Encoding.GetEncoding(Int32)
at ICSharpCode.SharpZipLib.Zip.ZipConstants.ConvertToString(Byte[], Int32)
at ICSharpCode.SharpZipLib.Zip.ZipConstants.ConvertToStringExt(Int32, Byte[])
at ICSharpCode.SharpZipLib.Zip.ZipInputStream.GetNextEntry()
at ZIP.ZipHelper.UnZip(System.String, System.String, System.String)
at JZredLMd7tOuuv3X36.ujVVjwQw8Vonovrbro.euoXeVYd4b()
at JZredLMd7tOuuv3X36.ujVVjwQw8Vonovrbro.N78XgRgIrT()]

I’m not sure what is causing this error, but I suspect it might be related to the software’s use of the ICSharpCode.SharpZipLib library. It looks like the library is having trouble converting a byte array to a string using a specific character encoding.

If anyone has any suggestions for how to fix this issue or has experienced something similar, I would greatly appreciate any help or advice. Thanks in advance!

There’s your problem. You’re using Win 8 lmao.

I’m on Windows 11 Dev builds and haven’t had any issues. I even just got an update this morning that went through fine. You’ve already plugged both the mouse and dongle in, right? Make sure you’re using the original cord for the dongle. And make sure you’re using a good cord for the mouse. Otherwise I don’t know. Maybe completely reinstall the software fresh.

I’m also on Windows 11. I had some core Windows services disabled hence the app was failing. I’ve just updated the firmware through a fresh install of W11 in a virtual machine (not recommended for anyone with no experience to try this out and I take no responsibility if you do).

thank you so much not going to lie you help me so much with update I was going crazy trying to understand why it wouldn’t update!!!

What was outcome to this? Did you manage to update mouse?

I have similar issue with Model D Wireless.
Update will give same error in event logs.

Application: FirmwareUpdate.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ArgumentException
at System.Text.Encoding.GetEncoding(Int32)
at ICSharpCode.SharpZipLib.Zip.ZipConstants.ConvertToString(Byte, Int32)
at ICSharpCode.SharpZipLib.Zip.ZipConstants.ConvertToStringExt(Int32, Byte)
at ICSharpCode.SharpZipLib.Zip.ZipInputStream.GetNextEntry()
at ZIP.ZipHelper.UnZip(System.String, System.String, System.String)
at JZredLMd7tOuuv3X36.ujVVjwQw8Vonovrbro.euoXeVYd4b()
at JZredLMd7tOuuv3X36.ujVVjwQw8Vonovrbro.N78XgRgIrT()

OS WIN 11

I have resolved the issue. In my case, it was that FirmwareUpdate.exe does not properly handle the en-fi locale, and probably other locales as well.

Simply change your system’s preferred language and region to en-gb, for example, and it should work.

May those who find this post useful avoid the suffering I endured in figuring this out."

1 Like