Model I Software Issue

So I have the Model I as well as a GMMK 2 and I opened the Glorious Core software to change some of the lighting on my keyboard when a message popped up asking if I wanted to update Glorious Core. Obviously I clicked yes. A few seconds later, and before it did anything, it asked if wanted to update my model I, instinctively I clicked yes on that as well. It then brought up the update loading bar but then, almost immediately the Glorious Core software crashed (I would have to assume since it immediately disappeared). The mouse was then unusable with the scroll wheel blinking red. I attempted reopening the software but the mouse was no longer detected by it. I looked for any fixes or anyone with the same or a similar problem but couldn’t find anything (almost al the results were for model o anyways). I then recalled having had this happen before when I first got the mouse and remembered a fix to it that I had found here (Model I - Not working after Core/Firmware update (Red Flashing Scroll Wheel)). I tried running it to see if it would fix it but instead it simply stopped flashing red and is now unable to be detected by my computer at all (not just the Glorious Core software).
Apologies for the length of that but I was wondering if anyone on here had any suggestions or experience with a similar issue before I try contacting Glorious Support.
Anyways, thanks in advance!

Sorry to hear you’re having issues with the Model-I and the software update. Unfortunately, this isn’t the first time someone has mentioned this issue, nor the first its happened to me. I would suggest contacting Glorious support by way of either email or live chat, 8am - 8pm CT (1pm - 1am GMT/BST).

I had the exact same thing happen to myself yesterday, and followed the instructions of one of our guild members to resolve the issue (thanks again @zealot9802). The following link will take you to the post and the instructions.

This should get the mouse functioning again, but it will not be running the most current version of the firmware. Since the mouse will prompt another update message the next time Core is opened, I suggest declining that for the time being and following through with asking support for help. They may be able to get you the current firmware version, but it will at least show them that users are encountering issues.

1 Like

To 8-bit_bootcamp
I am having the same problem, but I cant access the instructions because of guild walls. :frowning: Is there a way to get the I up and running?

You can restore the Model-I to its factory settings by pressing and holding the mouse 1, mouse 2, and scroll wheel at the same time. The RGB will flash green 10 times and reset the settings. This will wipe the current profile from the mouse, but not from the Glorious Core software. So you can open Core after the reset, and simply click “save” to set the profile as it was prior to the reset.

Hope this helps and so sorry the update caused issues with your Model-I.

Does the USB have to be plugged in?

I have completed the steps, however, the RGB side panels are glowing red now, and the cursor is still not moving :frowning:

The only time I’ve encountered the flashing red RGB on any of my Glorious mice was after an error during an update. The reset feature has always managed to fix the problem for myself, so I’m at a loss for an immediate fix beyond that. I would highly recommend contacting Glorious support and asking them for assistance.

Ok will do :smiley: Thank you so much for your responses and your time!

No problem, best of luck getting the problem sorted.

My problem is when I open the software it just closes no matter what I’m doing it closes after a few seconds. I tried everything but it’s still not working. Is there a way to fix that?

And it only happens with my model i

I had a similar issue when I got my Model I on launch. Try running the software to update firmware or update settings in Windows Safe Mode.