Model I 2 wireless sleep

I have the I 2 and while it’s my favorite Glorious mouse, I find that it never goes to sleep. Ie; the RGB is on all the time. This severely limits the battery life compared to every other mouse I own (and I have a lot, Glorious included).

There’s an option in the software to lower the RGB brightness when in wireless mode, but that’s no quite what I’m looking for. Most mice go into some kind of sleep state when they haven’t been used for a few minutes, which can make the battery last for weeks. For the I2, it’s more like a few days.

Any thoughts?


Mine doesn’t sleep either. And usually when I put my PC to sleep, the I2 will wake it back up. Really annoying.

1 Like

My I2 is hard-wired because of this issue, and it has been this way for six months. Moronically annoying at this point…

Hey all, I checked with our SW/FW team and it sounds like you may not be using the inactivity timer.

Basically, there is a firmware default of 7 minutes, but CORE overwrites the default automatically so that the mouse will respect the user’s setting instead of the default. But if you aren’t using the inactivity timer, then CORE is wiping out the default but not applying a new setting (because the user hasn’t configured it).

However, it’s always best to reach out to our CS team to solve the issue as I don’t know all the specifics of your setup and they’ll be better able to troubleshoot.

1 Like

I don’t have core set to run in the background. I’ll charge it up again and reboot and see what happens.

1 Like