Model D wireless update failed

I’m trying to update my Model D wireless via Glorious core. However, when I press download, it waits for a couple of seconds, and then fails to update. I get this error “FIRMWARE UPDATE FAILED: Device not found. Verify that the device has both its cable and receiver plugged in.” I do have the receiver plugged into the laptop directly and also connected my mouse via a USB C to USB C cable, however, it still wont update. Any advice would be greatly appreciated. Thanks!

Not sure if it will help but do you have the stock cable that came with your Wireless D? Try the update with that cable instead, also you can try cable and without the adapter plugged in. See if either of those work.

You may also want to uninstall Glorious Core and reinstall fresh from the site: Glorious Gaming - Glorious Core
(I tried to link directly to the wireless D for you) but find Core for your mouse and install and try to update your firmware again.
Update us as you can & Remain Glorious, @syedurashid!

Thanks for the reply. I don’t have the stock cable, but I found one that works. However, glorious core now updates and gets stuck at 150%. Its been like that for the past hour or so. Not sure what to do. Please advise. Thanks!

Update: I found your guide on reddit, and followed the steps on there, and it worked! Thank you for all the amazing help!!


Way to sort it out, @syedurashid! Keep enjoying and Happy Hunting!

  • IC
1 Like