Model D Wireless erratic scrollwheel and tracking

I picked up a Model D wireless around xmas '21 so it’s over a year old. For about 2 months now, the scrollwheel has been erratic: scrolling down will skip or scroll up, even on this web site. Also, it seems to frequently lose tracking. If I’m playing an FPS and tracking someone while shooting, it will suddenly stop, then continue. I’m using a glorious deskpad, btw.

I read it could be dust on the contacts so I bought compressed air to try to blow the dust out (didn’t really notice any thought I’m sure there was some). It seemed to help at first, but the mouse is getting worse now.

Any ideas on how to fix this?


I don’t have a solution, but recently ran into the same issue with tracking and tried to section it down to a similar issue, I even made sure to wash my glorious ice mouse pad since I didn’t want potential grease/cat hairs to become a part of the problem. Upon cleaning my mouse with tweezers and compressed air, it still persisted to have tracking problems. I pulled my $25 CAD Logitech G203 out of my old tech bin just to test, and it is now my replacement to my model D wireless as it is literally functioning with no trouble even after being put to use after not even dusting it. I can hear the skates on my g203 scraping on my mouse pad and it still tracks more smoothly. I have no solutions, but hope this helps you feel less crazy.

1 Like

Thanks. This is kind of what I was afraid of. I bought my son a model o- wireless at the same time and it still works perfectly. I’m guessing it’s a quality issue. Maybe I can RMA. I have an old wired razer that works fine, maybe I should switch back in the meantime.

Thanks again for sharing your experience.

Hey Rainy Dave, welcome to the Guild!

I’d definitely recommend contacting Glorious Support with your issue.

Something you can try in the meantime is resetting the mouse, and making sure you’re running the latest firmware. You can reset the mouse by holding the left click, right click, and middle mouse button down for about 5 seconds. The mouse will start blinking green, then you should be able to release the buttons. This will clear your profiles and set the mouse to the factory defaults, then open the Glorious software and check for updates!


I doubt this is the reasoning, but I was shocked by it so I figured it might be worth mentioning.

Where do you have the USB receiver plugged in on your PC? I’ve never had it happen with Glorious mice, but pretty much all my Razer, Finalmouse, Pulsar, and Logitech mice run into issues specifically when I have them plugged into my front USB headers, and then connecting something ELSE to my front USB headers.

I’d try swapping around the port you’re using, and if at all possible try removing anything that isn’t vital to the function of the PC and see if it resolves the issue. Once I removed my card reader and stream deck everything worked fine again.

1 Like

Hi, thanks everyone for your help, anecdotes, and suggestions. I tried everything and ended up contacting support and an RMA has been issued.
Thanks again!