Menu (FN) Key

Just built my GMMK Pro, also my first ever build. Loving it, but there is one key that’s not registering. The menu key doesn’t show any input. I tried different switches, switches that work in other slots, but no change.

Not like I will ever need that key but what should I be looking at to troubleshoot why it’s not functioning.

I pretty much took the GMMK pro out of the box and built it this morning.

Anyway, any advice/insight would be much appreciated!

Cheers!

3 Likes

Sorry to hear that’s happening. Have you made sure to download glorious core and go through a firmware update?

If you already have, I would recommend forcing another try with firmware (I am not 100% on how to do that). Other than that I would contact glorious support.

Keep us posted on your progress. I would want all my switches working too, even if they are not ones used often or at all in regular use.

1 Like

Is it the fn key? I know some keyboards that key only works if you press it with another key to do commands like switch layers or something. Haven’t used my pro in a minute tho.

2 Likes

I was about to say the same thing. The FN key never shows up on a switch tester, so I always have to test it through key binds. This is also part of the reason I suggested Glorious add a tester to the Core Software.

4 Likes

@jzaine7 @8-Bit_Bootcamp Yes, the fn key. I tried a few different keyboard testers but I couldn’t get it to register. I was unaware that it doesn’t show up such software. I’ll try again today and see if it’s working.

Hmm, it is working. If I ctrl + fn + up arrow key, it cycles thru some keyboard effects, then using the ripple graff effect in glorious core, it activates when pressing the key.

I guess it threw me off because 1, it doesn’t register a key press in keyboard testing software, and it doesn’t do anything outside of glorious core atm. I thought it was supposed to function as a right click on a mouse. But in word and other software it’s not opening up a menu.

@misoandricegamer I noticed this too and not to worry. It sucks you can’t reassign it in Core. Try holding Fn while on your desktop and hitting F10 or F11. Mine toggles the volume if you hold it and doesn’t if you don’t.

1 Like

@xXiceXx Thank you, I tried it just now as you suggested. I guess the key itself is working fine. Much appreciated.

1 Like

Thanks to everyone that responded here. Much appreciated. I guess I’ve found that they key is working with shortcut functions. Just not doing anything in applications though.

2 Likes