LEDs of the GMMK Pro stopped working

Hello everyone!

My GMMK Pro’s LEDs have suddenly stopped working.
The keyboard still works fine on the other hand.

I have tried switching between the profiles and reinstalling Glorious Core but it has not changed anything.
Tried a different USB cable but that did not change anything neither.

Any help welcome!

That’s no good! I would try a reflash of firmware to see if you can get it to start up again. It’s on the setting screen of core.

If that’s a swing and a miss, contact glorious support. They will have more options for you to try. They should be able to get you taken care of.

Thanks for the suggestion!
Unfortunately, it did not work.

I will contact support I guess.

Try a full reset using the qmk software. Download the QMK software and the firmware you want, run QMK and load the firmware package. Then disconnect the keyboard, hold down the space bar + b and plug it it. It’s should recognize the board. Now press Flash and it’ll reflash the board.

I went through this process just recently with support. They may need to link you to the qmk

1 Like