LED Brightness issue with my Model D wireless.


I’ve set my wired and wireless brightness at 5%, single color (R-0, G-255, B-155). Thing is though, when I plug in my model D to charge through USB the brightness shoots up to max 1 second after being plugged in. When I unplug the mouse, the brightness stays at 100% and I have to go back to the Glorious Core app to lower it back to 5%. Small issue as everything works almost well, but it’s an annoyance to be tweaking in the app everytime.

Things I’ve tried:
-update firmware
-factory reset (left + middle+ right, 5~secs)
-reinstall the Core app (core app run as admin by default set in properties)

Interestingly enough, this does not happen when I charge the mouse using my phone’s charger or through a third party charging only cable connected to the PC. Hopefully someone has any insights/ideas about this.



I wanted to update that I found out the cause after like, half a day of trying to use the Core app to tweak and also the mouse button combinations to change brightness (and also trying to check any conflicting apps).

What I found out is that the app Signal RGB (using it to control my case fan RGB) was overriding whatever brightness I set in the Core app. Disabling Wireless model D in Signal RGB did the trick. I think I can consider this solved.

Soo a bit of a PSA… just use the Core app OR Signal RGB to control the lighting and never let both control the mouse lights at the same time.

1 Like