Keyboard Connection Issues

Backstory :

My setup is run by a laptop, not a PC. I have it tucked to the side, and it is always open, meaning you can see the keyboard, etc.
Recently, I lubed my switches on my GMMK pro and they sound amazing! Now mind you I have 2 GMMK Pro’s, which which perfectly fine before I lubed the one.

After lubing, I plugged it into my computer and it did not work. Neither did the keyboard on my laptop. Then, I plugged in my other GMMK pro and that didnt work either. (the one I did not lube).

I grabbed an office keyboard and It worked fine. Has anyone had problems like this or suggestions to help me fix it?
Everything is appreciated.

Edit : This has been going on for about 2 weeks.


I don’t have a laptop but when I plugged in two GMMK Pros and they didn’t work I went to the windows “Bluetooth and other devices” in settings and deleted the two GMMK Pros, made sure I only had one plugged in, and let it reset the config. Then I restarted my PC with it plugged in and it started working. Not sure if this advice would work for you too but I don’t think it would hurt to try :person_shrugging:

1 Like

thanks for the info! I’ll try later when i’m home.

Edit : unfortunately didnt work, maybe I need a new keyboard/mouse driver. I will keep searching. If anyone else has suggestions please let me know!

Another thing I noticed was that my mouse clicks are weird too sometimes.
Say if I search something up, and go to the next page of results, it will download an htm file. (Same with clicking other, normal buttons.)
Another thing is clicking bookmarks I have saved, it wont work. (I use Microsoft Edge).

Tried on another computer so I doubt it is a virus.

After I lubed my Pro I had the same thing no lights, nothing. So I went to Core and update the software. That worked. Happens a few times now if I swap out keyboards.

1 Like

Mine still has lights, and core is completely updated. Thanks for the idea though!

1 Like

@SwaggyAlpaca I am curious about what kind of cable you are using. Is it the stock straight cable or a coiled cable (Glorious or other)?
I ask because I have found issues with the Glorious Coiled cables (I have two, nebula and white and both do the same thing) and having that type of issue occur. Mine specifically was the same kind of “not registering” and there were two remedies for me.

  1. If you can get into core and see the keyboard do a firmware update on the board.
    If the board still isn’t having it:
  2. go into the settings (lights, performance, etc), and do a “restore to defaults” on all the tabs. This should bring things back to right.

If not, read further my friend, as I have dealt with these types of woes in general :slight_smile:

For your system overall and its health you can do a few things as well:

  1. make sure you have all your updates and not just through windows updates. Go to your manufacturer’s website and see what is available if you haven’t.
  2. Use ADWCleaner to run a quick scan on your machine. Even if you have Antivirus/windows defender or other. It’s good to remove garbage collected from general use and freshen up windows.
  3. Open Command Prompt as Administrator and run SFC /SCANNOW
    This performs a check on all of windows’ stuff and will run repairs on anything out of place and will let you know if it did.

If all else fails trying a different USB cable might do the trick. I personally have only been using Glorious stock cables for my Pros and have been okay since dealing with it being buggy for a few weeks myself and I got sick of doing the restore dance with them :rofl:

Let us know!

1 Like

Like Indigo said, coiled cables can be more power demanding. I find if you plug them into a powered USB hub, they will work.

In addition, I find the Glorious Core software to be… lacking. I suspect it has conflicts with some other software, but I didn’t have the time to figure it out. I flash all my GMMK Pros to QMK, and they work that way whereas I’d have power issues with the default firmware.

BTW, the lighting coming up but the KB not working was exactly what happened to me too.

Drawbacks of QMK: caps lighting won’t work, lighting itself may not work (but I don’t care about that - I heard it does now), and it uses “raw” qmk, so you can’t change things on the fly with VIA. It’s possible these things do work now and I just haven’t created a new qmk firmware in a while.

I think the problem may begin to manifest itself when you start swapping keyboards around / removing them from the port. I didn’t have any issues either until I started doing that, and if my GMMK Pro worked once plugged in, it would continue to do so until I unplugged it. This would track with what you saw unplugging one and lubing it up (giggity).

1 Like

Thank you! Sorry for the late response, I sometimes forget to check this. I am using a stock glorious cable and have tried a 2nd one, both do not work. I will further update you once I have tried other things!

1 Like

Forgot about this! I have later found out the only the black GMMK Pro was not working, and the other is working fine. I will be opening a support ticket later this week with CS.

1 Like

Have you tried to do a factory reset? I had the issue of the board not working but if I did a factory reset it would take care of the problem

Restore Keyboard to Factory Default Settings
(Hold for 10 Seconds)FN + ESC then F1 + F3 + F5

Yes, I have.

Thank you though!

1 Like