Hard reset doesnt work on Model D Wireless

So I have an issue with the Back Button (MB 4) not working at all, and I also had an issue where it just “pressed itself” automatically sending me back one page on the browser for example. Now it doesnt do anything anymore. I also tried retrying the firmware update in the driver and found out that there is an hard reset function. It just doesnt work? Its LMB + RMB + MW Button for 5 seconds. It should flash but it doesnt. No matter how long, how hard I press or if its wired / unwired.
Thanks for any help in advance.

So the M4 button is either not working, or randomly registering presses? That would definitely drive me up the wall. As far as I am aware, pressing and holding M1, M2, and scroll wheel for 5 seconds is the factory reset for all the Glorious mice.
Since you said you already tried reinstalling the firmware and factory hard resetting, Id recommend contacting Glorious support directly. The support team may have other suggestions on troubleshooting or replacing the item if its under warranty.

1 Like