GMMK Pro - Lights turn on, volume control works, but keys don't work.

The lights turn on, the Glorious app reads the connection, even the volume control works, but none of my actual keys work. This started happening when I unplugged the keyboard and plugged it back in. Right before, all my keys were working.

Another weird bit of information - if I put both of my hands on many of the keyboard keys and press them all down at once, it begins to read the keys, but when I take off both hands, it goes back to being unresponsive.

Anyone know where this issue could stem from?

I experienced this as well. I think it might have to do with Glorious Core and a possible conflict as flashing the board with QMK solved it. However, you may lose out on some functionality doing that.

Flashing with core might solve it too until you unplug it again.

You can also try reaching out to support.

That’s pretty weird! Do you have a PE foam sheet installed? I find that sometimes it can cause switches to not properly fit into the sockets, which causes things to appear normal but none of them would register key presses.

Have you tried to restart the keyboard? I had mine do that to me a couple times when I first got it and all I had to do was a factory reset by pressing FN + ESC then F1 + F3 + F5

I have this happen to me every time I open up my keyboard to mod it. An easy fix is to reinstall the firmware to the keyboard.

  1. Go to Glorious core software.
  2. Settings
  3. on the right side you’ll see options like ‘startup’ ‘minimize’ etc. find retry firmware update, then select the device you’re trying to update.
  4. Make sure your keyboard is plugged in.

This fix takes less than 30 seconds and is really easy to do.
My keyboard hasn’t returned to this state for a while, they might have fixed it with a software update.
Hope this helps