Glorious model D wireless stopped working


I have glorious model D wireless that’s been working good ever since i bought it, it was working until it suddenly stopped working i mean lately when i plugin the cable it just keeps flashing and doesn’t work until the flashing stables and still doesn’t work, so it only woks when unplugged (wireless) that doesn’t mean that it doesn’t charge while plugged in. Now when plugged in it doesn’t even light up it doesn’t work and when unplugged it doesn’t light up either but still i get something in glorious core but still it doesn’t even show the charge bar. So basically it doesn’t work, after some time plugged in it lights itself up randomly and can work wireless and not plugged in so basically now it works randomly when i leave it plugged in (with cable), but most of the time it doesn’t work.

Hi @skander123 feel free to see if anyone has any advice on your issue, but in the meantime I would recommend contacting support here. Hope you get it fixed!

Hi, thank you for your reply. Actually contacted support but since it’s out of warranty there’s nothing they can do…