Does the GMMK Pro not allow me to access BIOS or use it in BIOS?

Hey y’all. Ran into a problem today where I couldn’t access my PC bios hitting the Del or F2 keys on my GMMK Pro. When I used the windows recovery method to reboot into my BIOS directly, I couldn’t use the arrow keys or any of the F buttons inside my bios. It is plugged directly into my mobo. I just got it, so this isn’t something that worked before and doesn’t work now.

Is this just how this keyboard works, no access outside of Windows? Kind of a bummer if I need to plug in another keyboard when I need to change a setting or something, because my old NK65 worked as normal in my bios.

Honestly, the keyboard should work at bios level access.
I have had issues where my GMMK PRO will drop its connection and I have to use core to flash the firmware to get it working again. This started about 4 months ago for me (and is intermittent) but it’s sounding like it is hitting during a sucky time for ya cause you need it.

If you have another system you can install core onto and flash the firmware you should be good.

Just make sure that power to the machine is off and disconnect the power cable till after the keyboard is plugged in. Go for the top left most USB port for the keyboard as well (unless that is your bios update port).

Keep us posted and Good Luck!

Edited text cause high, sorry. :rofl:

1 Like

Luckily my PC is doing ok, I just needed to change a BIOS setting and couldn’t get in no matter what I tried with my GMMK Pro, it was like it wasn’t activating until Windows loaded.

My other keep worked just fine, and my mouse was working in bios too, so I was able to set things.


Good work around! Glad you got it sorted :smile:


Long time coming, but I think I figured out the problem. The mouse I was using, the ROG Chakram, has a little joystick built into it on the thumb side. That shows up in the device manager as a seperate keyboard, and the BIOS of my new mobo was detecting that keyboard before my real one, so it never activated the GMMK Pro.

I’ve since swapped that out (the battery was starting to go, so this was just the final straw) and haven’t had a problem since!


W update!

1 Like