Cannot update firmware

When i update my mouse, i hear a ton of unplug and plugin sounds, one time it said Glorius bootloader was plugged in. my software is up-to-date, but the firmware isn’t, my mouse is a Model O wireless, and Firmware, when it gets to 50% it stays there then says the dongle was unplugged, i do not have my mouse or dongle plugged into a USB splitter, its directly in the motherboard ever since i got the mouse about a year or so ago i haven’t been able to update it, how do i update the thing

i also have tried connecting the mouse with the original cable and that’s a no-go, also the receiver isn’t the original, i lost the og.
here is also a video of me attempting the install

You have both the mouse and dongle plugged into the computer? I seem to recall having this problem until I made sure both were plugged into the computer.

correct they are

do u have any other ideas?

1) Make sure you have the mouse connected in Wired mode. Not Wireless.

2) Make sure the USB Dongle is connected to your computer directly into the USB port.

3) Make sure Glorious Core is running as Admin.

Have you paired your new dongle? There’s a Glorious Pairing Utility in Core

You can also try Glorious support Team

yep tried all 3 at same time, the dongle is paired (considering the fact that my mouse is working), the model O wirless shows that its connected but it only shows the model o 2 wireles and model I 2 wireless in pairing section of the app, i these sounds in order, unplug, unplug, instantly after plugin, unplug, instantly after plugin, and than it stays at 50 and fails

Try this one? I’m guessing it has to do with the dongle not being original.